読者です 読者をやめる 読者になる 読者になる

彼女からは、おいちゃんと呼ばれています

ウェブ技術や日々考えたことなどを綴っていきます

Yosemite にアップブレードしたら RubyMine が頻繁にフリーズするようになった

諸般の事情により今月ようやく Mac OS を Mavericks から Yosemite にアップグレードしました。そうしたら RubyMine が頻繁にフリーズするようになったので対処等を簡単にメモしておきます。

環境

不具合の内容

  • 頻繁にフリーズするようになった
  • Window > Editor Tabs > Close All メニューを使うと必ずフリーズ
  • 待機しても応答なしなので、仕方なく毎回強制終了していた

原因

  • Yosemite にアップグレードしたことにより、Java のバージョンが変更された
  • Java 6 -> Java 7 が使われるようになった

対処方法

以上です。

おまけ

  • RubyMine が使用している Java のバージョン確認は、メニューから「About RubyMine」を選ぶ
  • /Applications/RubyMine.app/Contents/Info.plist で RubyMine が使用する Java のバージョンを指定できる。こちらの環境では下記のようになっていた
<key>JVMVersion</key>
<string>1.6*,1.7+</string>